Notes on Joomla 3.x compatibility

From HAA Best Practices Wiki
Revision as of 19:13, 8 May 2014 by Whbean65 (talk | contribs)
Jump to: navigation, search

Last updated 5/8/2014

There are major changes between Joomla 2.5 and 3.x. Here's the status of the components we use:

  • Community Builder 1.9.1 is compatible with 3.1 and is installed on sites.
  • Upgraded GMaps Pro 1.0 to work with Joomla 1.6. We are on our own here.
  • Event List. Beta version 1.0.2 works in 1.6. JEM has forked the project and may be working on 3.0. (But it doesn't look as though much is going on.)
  • Expose Prive - only in legacy mode - Have modified to work in 1.6. We're on our own.
  • Kunena - 3.x compatible. Installed on all sites.
  • Sticky Message Pro - New paid version available that runs on 3.x
  • CB Mailing - we've edited so heavily we will have to deal with it.
  • Google Analytics Bridge - seems to be gone but there are lots of 3.x-compatible modules to do the same thing.
  • Google Verify - seems to be gone but there are lots of 3.x-compatible modules.
  • CB Photo Gallery - Latest version suports 3.x. Need to renew Joomla Advanced account to get access.
  • Alternate Home works in 1.5 Native. Modified xml, works in 1.6. Need to check in 3.x
  • All Videos. Latest version works in 3.x
  • Login Redirect - Need to test
  • Add yourself to the reunion attendees - Need to test
  • Summary reunion list - Need to test
  • HAA Reunion Mgr admin - Need to test
  • HAA Reunion CB plugin - Need to test
  • HAA Spam filter - Need to test

Also we need to develop a conversion program to migrate the existing sites onto the new version. This will be a fairly complicated process.

As expected a preliminary upgrade to 3.3 fails miserably. It looks like it will take a lot of work to get this going. The first version of 3.x that will be offered long-term support is 3.5. Probably we should wait for that to come along.

Return to main Master Template page